Hjem > Meninger > Utvidelser som ikke er testet med din versjon av WordPress

Utvidelser som ikke er testet med din versjon av WordPress

av naldy
Utvidelser som ikke er testet med din versjon av WordPress

Har du noen gang installert en utvidelse som gir advarsel om at den ikke har blitt testet med din versjon av WordPress? Bør du da bruke den, eller velge en annen?

I dette innlegget forklarer vi om du bør installere utvidelser som ikke er testet med din versjon av WordPress, og hvordan du kan hjelpe WordPress-fellesskapet.

 

Når du installerer en utvidelse fra Utvidelser > Legg til ny, vil du iblant se en advarsel om at utvidelsen ikke er testet med din versjon av WordPress.

Utvidelsen har ikke blitt testet

Hvorfor viser «ikke testet» advarsel

Det offisielle arkivet hos wordpress.org inneholder den største samlingen av gratis utvidelser for WordPress.

Når utviklere laster opp en utvidelse til wordpress.org, må en fil med detaljer om utvidelsen legges ved. Denne filen blir lest av systemet, og danner grunnlaget for siden til utvidelsen.

Denne filen med detaljer om utvidelsen, må også inkludere informasjon om hvilken versjon av WordPress utvidelsen er laget for.

Det blir forventet at utvikleren holder denne informasjonen oppdatert. Det betyr at for hver ny versjon av WordPress, må utvikleren oppdatere filen med detaljer.

I en ideell verden ønsker vi at alle utviklerne oppdaterer denne informasjonen fortløpende, men dessverre er det ikke alltid slik.

Husk at disse utvidelsene er gratis, og du betaler ikke noe for å laste ned og bruke de. Mange utviklere publiserer utvidelser på fritiden sin, og har ikke alltid tid eller ønske om å følge opp utvidelsen i ettertid.

 

Bør du installere disse utvidelsene?

Vanligvis er det helt ufarlig å installere og bruke utvidelser som gir «ikke testet» advarsel. Selv om utvidelsen ikke er nylig oppdatert, vil den kunne fungere helt fint på nyeste versjon av WordPress.

Hvis du har blitt anbefalt en utvidelse fra WPologi, kan du anta at vi har testet utvidelsen med nyeste WordPress versjon tilgjengelig da innlegget ble skrevet.

Her hos WPologi kan du til enhver tid se når et innlegg sist ble oppdatert øverst på siden, under innleggets tittel.

Utvidelser som ikke har blitt oppdatert på mer enn to år, bør du derimot ikke installere. Så gamle utvidelser er ikke lenger vedlikeholdt, og trolig forlatt av utvikleren.

Utvidelser som er forlatt av utvikleren kan inneholde dårlig kode, og kan ofte forårsake feil på nettstedet ditt.

 

Hvordan kan du bidra til fellesskapet?

Om du ønsker å bidra til fellesskapet, kan du installere utvidelsen og teste den. Hvis utvidelsen fungerer som forventet, bør du gå tilbake til siden for utvidelsen, og registrere en tilbakemelding.

Logg inn på wordpress.org med brukernavn og passord, og registrer en omtale. Skriv hvilken versjon av WordPress du bruker, og hvilke erfaringer utvikleren eller andre kan dra nytte av.

Registrer omtale

Hvis du har prøvd en utvidelse som er ødelagt eller ikke virker, kan du skrive en tråd i supportforumet til utvidelsen. Hvis du ikke får svar, kan du eventuelt kontakte utvikleren direkte.

Vær oppmerksom på at utvikleren ofte er avhengig av en detaljert tilbakemelding for å kunne rette feil.

Kanskje du liker

Skriv en kommentar

* Vennligst gjør deg kjent med vår personvernerklæring.

Vi benytter cookies for utvidet funksjonalitet, bedre nettleser-opplevelse, statistikk og målrettede annonser. OK Vis mer

LIKTE DU INNLEGGET?
MELD DEG PÅ NYHETSBREV!
Send
Nyhetsbrev sendes ut ca. hver 3. måned.
LUKK